Repository navigation
fix(wren-ai-service): upgrade litellm to 1.83.7 (SQL injection CVE) - #2207
Conversation
…CVE) CVE affects litellm >= 1.81.16, < 1.83.7 (proxy API key verification path). Bumping required loosening ollama and ollama-haystack constraints because litellm 1.83.7+ requires httpx 0.28.1 while the old ollama ^0.2.1 pin required httpx <0.28, which is what blocked Dependabot's auto-update. - litellm: ^1.83.0 -> ^1.83.7 (resolves to 1.83.14) - ollama: ^0.2.1 -> ^0.4.0 - ollama-haystack: ^0.0.6 -> ^2.0.0 Co-Authored-By: Claude Opus 4.7 (1M context) <noreply@anthropic.com>
|
Caution Review failedPull request was closed or merged during review WalkthroughDependency version constraints in ChangesDependency Version Bumps
Estimated code review effort🎯 2 (Simple) | ⏱️ ~8 minutes Possibly related PRs
Suggested labels
Suggested reviewers
Poem
🚥 Pre-merge checks | ✅ 5✅ Passed checks (5 passed)
✏️ Tip: You can configure your own custom pre-merge checks in the settings. ✨ Finishing Touches🧪 Generate unit tests (beta)
Tip 💬 Introducing Slack Agent: The best way for teams to turn conversations into code.Slack Agent is built on CodeRabbit's deep understanding of your code, so your team can collaborate across the entire SDLC without losing context.
Built for teams:
One agent for your entire SDLC. Right inside Slack. Thanks for using CodeRabbit! It's free for OSS, and your support helps us grow. If you like it, consider giving us a shout-out. Review rate limit: 7/8 reviews remaining, refill in 7 minutes and 30 seconds.Comment |
Summary
litellmfrom^1.83.0to^1.83.7to patch the proxy API key verification SQL injection vulnerability (affects>= 1.81.16, < 1.83.7). Resolves to1.83.14in lock.ollama(^0.2.1→^0.4.0) andollama-haystack(^0.0.6→^2.0.0) — required because litellm 1.83.7+ pinshttpx == 0.28.1while the oldollama ^0.2.1capped httpx<0.28. This is what blocked Dependabot's auto-update.Router,acompletion,aembedding); no proxy server is started. The vulnerable code path is in litellm's proxyPOST /chat/completionsflow, which is never executed here. Upgrading still recommended to stay current and clear the alert.Test plan
poetry lockresolves cleanly with no version conflictspoetry installsucceedsfrom litellm import Router, acompletion, aembeddingsrc.providers.llm.litellm,src.providers.embedder.litellm,src.config,src.globals— all OKpytest --collect-only tests/pytest --ignore=tests/pytest/evalcollects 100 tests with no errorsjust testagainst Docker pipeline deps (Qdrant + engine) — to be run in CI / by reviewer🤖 Generated with Claude Code
Summary by CodeRabbit