You signed in with another tab or window. Reload to refresh your session.You signed out in another tab or window. Reload to refresh your session.You switched accounts on another tab or window. Reload to refresh your session.Dismiss alert
That <3.0.0 cap means beancount-exporter can't be installed alongside Beancount 3.x, which is now the active major series for most of the ecosystem (Fava, beangulp, beanquery, beanprice, redstreet's importers/plugins, etc.).
Where it bit me
beanhub-cli >= 3.1.0 picked up beancount-exporter>=3.0.0 as a direct dependency, which transitively makes beanhub-cli 3.1.x uninstallable on Beancount 3.x. The uv resolver spells it out:
Concretely: I'm on beancount==3.2.2 and trying to upgrade beanhub-cli from 3.0.1 to 3.1.1. The workaround is staying on 3.0.1 (which doesn't pull in beancount-exporter at all), so I'm not blocked — just a bit stuck on the older release.
Possible directions
If beancount-exporter already works against Beancount 3 (the bits it touches — parsing, loading, options — haven't changed all that much), relaxing the cap to beancount>=2.3.5 (or <4.0.0) would do it.
If there's a real incompatibility behind the cap, it'd be helpful to know — a note in the README, or maybe a separate 3.x-compatible track, would let downstream packages like beanhub-cli target the right version on purpose.
Either way, thanks again for your work on this — happy to provide more details if anything's unclear.
Environment
Python 3.14
beancount==3.2.2
Trying to install beanhub-cli==3.1.1 (transitively pulls beancount-exporter==3.0.0)
Activity