Skip to content

Failing to backup MariaDB ALL #434

Description

@Gerben-W

Summary

Since version 4.1.20 I'm unable to create Mariadb Backups.
Within my config I have setup multiple databases to backup and only the MariaDB is not working.

Steps to reproduce

Running backup02-now

What is the expected correct behavior?

Creating backups of all MariaDB databases

Relevant logs and/or screenshots

2025-11-03.15:12:24 [INFO] ** [db-backup02] Starting Manual Backup for db-backup02
2025-11-03.15:12:26 [NOTICE] ** [02-mariadb.eth0__ALL] Dumping MySQL/MariaDB database: 'AVDTEST' and compressing with 'gzip'
mariadb-dump: Couldn't execute 'show events': Cannot proceed, because event scheduler is disabled (1577)
2025-11-03.15:12:26 [ERROR] ** [02-mariadb.eth0__ALL] DB Backup of 'mariadb_AVDTEST_mariadb.eth0_20251103-151226.sql.gz' reported errors
2025-11-03.15:12:26 [ERROR] ** [02-mariadb.eth0__ALL] Skipping Checksum creation because backup did not complete successfully
2025-11-03.15:12:26 [ERROR] ** [02-mariadb.eth0__ALL] Skipping moving DB Backup to final location because backup did not complete successfully
2025-11-03.15:12:26 [ERROR] ** [02-mariadb.eth0__ALL] Moving of backup 'mariadb_AVDTEST_mariadb.eth0_20251103-151226.sql.gz' reported errors
2025-11-03.15:12:26 [NOTICE] ** [02-mariadb.eth0__ALL] DB Backup for 'AVDTEST' time taken: Hours: 0 Minutes: 00 Seconds: 00
2025-11-03.15:12:27 [ERROR] ** [02-mariadb.eth0__ALL] Skipping Cleaning up old backups because there were errors in backing up

Environment

  • Image version / tag: 4.1.20 & 4.1.21
  • Host OS: UnRaid 7.1.4
docker run -d --name='db-backup' --net='eth0' --ip='x.x.x.x' --pids-limit 2048 -e TZ="Europe/Berlin" -e HOST_OS="Unraid" -e HOST_HOSTNAME="UnRaid" -e HOST_CONTAINERNAME="db-backup" -e 'MAIL_FROM'='no-reply@domain.com' -e 'MAIL_TO'='db-backup@domain.com' -e 'SMTP_HOST'='x.x.x.x' -e 'MAIL_PORT'='587' -e 'DB01_TYPE'='influx' -e 'DB01_HOST'='http://x.x.x.x' -e 'DB01_PORT'='8086' -e 'DB01_USER'='DB01_USER' -e 'DB01_PASS'='DB02_PASS' -e 'DB01_NAME'='ALL' -e 'DB01_COMPRESSION'='GZ' -e 'DB01_BACKUP_INTERVAL'='1440' -e 'DB01_BACKUP_BEGIN'='2350' -e 'DB01_CLEANUP_TIME'='2880' -e 'DB01_FILESYSTEM_PATH'='/backup/influxdb' -e 'DB01_INFLUX_VERSION'='2' -e 'DB02_TYPE'='mysql' -e 'DB02_HOST'='x.x.x.x' -e 'DB02_PORT'='3306' -e 'DB02_USER'='DB02_USER' -e 'DB02_PASS'='DB02_PASS' -e 'DB02_NAME'='ALL' -e 'DB02_SPLIT_DB'='TRUE' -e 'DB02_COMPRESSION'='GZ' -e 'DB02_BACKUP_INTERVAL'='1440' -e 'DB02_BACKUP_BEGIN'='2355' -e 'DB02_CLEANUP_TIME'='2880' -e 'DB02_FILESYSTEM_PATH'='/backup/mariadb' -e 'DB03_TYPE'='mongo' -e 'DB03_HOST'='x.x.x.x' -e 'DB03_PORT'='27017' -e 'DB03_USER'='DB03_USER' -e 'DB03_PASS'='DB03_PASS' -e 'DB03_NAME'='DB03_NAME' -e 'DB03_COMPRESSION'='GZ' -e 'DB03_BACKUP_INTERVAL'='1440' -e 'DB03_BACKUP_BEGIN'='0000' -e 'DB03_CLEANUP_TIME'='2880' -e 'DB03_FILESYSTEM_PATH'='/backup/mongodb' -e 'DEBUG_MODE'='FALSE' -e 'CONTAINER_ENABLE_MONITORING'='FALSE' -l net.unraid.docker.managed=dockerman -l net.unraid.docker.icon='https://raw.githubusercontent.com/A75G/docker-templates/master/templates/icons/db-backup.png' -v '/mnt/cache_pool/backups/database/':'/backup':'rw' --hostname=db-backup 'tiredofit/db-backup:latest

Possible fixes

Activity

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Labels

    Type

    No type

    Projects

    No projects

      Milestone

      No milestone

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions